El error se genera al usar una versión anterior a la 2.0 de ruby y se debe a que la configuración por defecto del framework no es UTF-8.

Esto lo encontré configurando la aplicación para producción, actualice la versión de ruby y listo, si no tendría que forzar cada cadena de texto a UTF-8

 

puts "\xC3".force_encoding('iso-8859-1').encode('utf-8') #-> Ã

Anuncios